Mapping Maschine MK2 (some issues)

  

Mapping Maschine MK2 (some issues)

Postby Will ZEgal on 09 Apr 2018, 22:10

Hi,

I'm working on a Maschine MK2 mapping for CrossDJ. But I experiment some issues.

First, the MIDI message receive window only show the received message for a very brief period, than it vanish. Si I have to click very quick on OK to keep it and have it bounded to the function.

And when I try to learn incoming MIDI, Cross often don't show up any control in the receive window, even if some MIDI it received. I have to press the button again and again until it works, than click very quick on ok not to loose it.

For instance, when I try to map a "locator clear", using a modifier and the previously affected button for the locator control, Cross play the locator each time I hit the button, but only display the modifier in MIDI receive window.

So creating a mapping is a nightmare while it has been quite easy for another controller (iCon iCreativ)

It doesn't seem to be a problem with Maschine controller because when some affectations are done (after much time and pain), they work quite good.

Except a problem with CC command and FX enable. I have the top row buttons of Maschine playing some CC. The first 4 ones have been affected to sample playing with success. But when I affect another one to FX1 engage, I have to press it several times to have FX on and several times to have it off although it has the same paramaters than the first ones (except CC number), having values from to 0 to 127.
When I tell this button to send a MIDI note, it works fine.

Thanks for any help.
User avatar
Will ZEgal
 
Posts: 40
Joined: 18 Nov 2011, 14:25


Re: Mapping Maschine MK2 (some issues)

Postby discopex on 11 Apr 2018, 18:28

This sounds a bit strange though, I've mapped Cross to several different devices (Reloop Contour, KMI Quneo, Novation Launchpad Mini, Novation Twitch, Reloop Mixtour, Allen&Heath K2) and haven't had this issue with disappearing parameters. Are there any possible adjustments to be made in Maschine (I'm thinking of some velocity curves et al) ?
Surface Pro 3 i7, 8 Gb, 512 SSD
running Cross 3.4.3 64-bit
Allen & Heath K2, Novation Audiohub
discopex
 
Posts: 488
Joined: 02 May 2007, 08:45


Re: Mapping Maschine MK2 (some issues)

Postby Will ZEgal on 11 Apr 2018, 19:35

Maybe (surely). That's what I'd like to know.

I've also tried with Maschine Jam and had no problem at all.

So it may be because of Maschine MK2's pads velocity or aftertouch. But I don't understand why as Cross doesn't seem to take in consideration neither velocity nor aftertouch.

Furthermore, when we perform some assignment with a knob, this one send more than one value to Cross, just like a pad with it's velocity and AT.

So what ? Strange...
User avatar
Will ZEgal
 
Posts: 40
Joined: 18 Nov 2011, 14:25



Return to Mapping Midi




Who is online

Users browsing this forum: No registered users and 10 guests

 
 
   
 
© 2014 Mixvibes