Page 1 of 1

Autoplay crashes + preferences not kept + bugs

PostPosted: 09 Feb 2020, 15:58
by RicoD38
Hi,

Autoplay is crashing around every 10 tracks on version 4.01 or 4.1.0 on PC :redface:
As well prefernces like type of fading is not stored : it's reverting to static instead of dynamic after crash :redface:

Setting MixControlPro as default / automatic force the software to wait forever if the device is not detected or not there : it doesnt even start

From time to time, it doesnt read/play some MP3s and crashes again even during analyze : it should not and flag those as with errors

Hoping to have those standard features fixed ASAP as it should not be too difficuly

Re: Autoplay crashes + preferences not kept + bugs

PostPosted: 09 Feb 2020, 23:18
by RoJeC
The writing of changed preferences only happens on normal quit of Cross. This has always been the case.

Crsahing during autoplay and analysis likely are related. I haven't seen anyone reporting this kind of issue with autoplay. I've run it for 100's of hours without issue.

There can be many causes for a track to have some kind of issue resulting in a corruption message. If you have crash files please provide to support@mixvibes.com so the error code can be added to the exceptions. If possible also provide an associated track file so the issue can be duplicated.

With repeating corruption usually a similar source of the tracks is involved.

Your issue with the MCP is not clear if this is MIDI or sound related. If sound please use the ASIO4ALL driver and set this to use the MCP. By this you can use the 64bit version of Cross.

In this situation analyzing non-analyzed tracks before using autoplay is recommended as this would clearify what causes the crash.

Re: Autoplay crashes + preferences not kept + bugs

PostPosted: 10 Feb 2020, 14:04
by Hanginon
V4.1 puts a huge load on the Resources/Graphics of a PC. My recommendation is don't use it in a live environment until they fix this - stick with V3.4.3

If you have to use V4.1, make sure all your files are Analyzed first - do not Analyze while playing.

Re: Autoplay crashes + preferences not kept + bugs

PostPosted: 10 Feb 2020, 17:54
by RicoD38
Crashing during autoplay and analysis likely are related. I haven't seen anyone reporting this kind of issue with autoplay. I've run it for 100's of hours without issue.
=> I'll give it another try tonight but it's likely to fail again : I'm rearranging on the fly the track list during autoplay based on requests mainly and I've found the crash being seen around every 10 tracks : memory leak or something related

How do I enable crash debug logs ?

MCP don't work on PC Cross DJ4.1.0 64bits maybe I need new ASIO4ALL drivers instead of U-Mix Control Pro / Pro2 1.0.5 Volume Panel so sticking to 32bits version for now

Re: Autoplay crashes + preferences not kept + bugs

PostPosted: 10 Feb 2020, 18:13
by Hanginon
RicoD38 wrote:MCP don't work on PC Cross DJ4.1.0 64bits maybe I need new ASIO4ALL drivers instead of U-Mix Control Pro / Pro2 1.0.5 Volume Panel so sticking to 32bits version for now

I only work with ASIO and 64 bits. I'd suggest you get a 64 bit DJ sound card that use's a real ASIO driver, use the U-Mix only as a MIDI controller, and run a 64 bit version of Mixvibes (preferably V3.4.3 as I mentioned above). You can get old Native Instruments (Traktor) Audio 2's dirt cheap (used), and they sound great. Do not get the new one with the Mini-USB jack.

Re: Autoplay crashes + preferences not kept + bugs

PostPosted: 10 Feb 2020, 22:53
by RoJeC
The MCP drivers are 32 bit only. Cross 64 bit only works when using 64 bit drivers.

For this you can download a virtual driver from asio4all.com.
Select the asio4all soundcard and then change settings of asio4all driver to use the MCP.

As mentioned by Hanginon you could consider using a different soundcard but should not be necessary.

Maybe you can consider to analyse a larger part of your collection to avoid the automatic analysis upon load of a track to deck esp in autolpaly mode.

A memory leak could be but would be strange that this seems to be a non general issue especially since it is after a few tracks only.

Re: Autoplay crashes + preferences not kept + bugs

PostPosted: 17 Feb 2020, 10:08
by gladblit
How do I enable crash debug logs ?


Kodi Lucky Patcher nox