Page 1 of 1

Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 11 Mar 2019, 19:45
by DJ Mate
Hello.
Recently I started using my Denon Mc-6000 Mk1 with Mixvibes Cross and I noticed strange thing about how "Monitor" section of MC6000 works. "Phones" volume knob works fine, but I think "Cue/Master Pan" knob works properly only in half of it's working range - from eqal cue/master to full master sound.
To be precise you can still use it by controller and make it show on screen like you made it into full cue but instead of full cue sound I get silence. Like I was turning cue volume down.
On the other hand it is not that annoying because I can turn to full cue sound by using mouse pointer on computer screen and turning that knob virtually.
I checked same thing in Tracktor Pro 2 and it works fine, so my controller is probably not a problem here.
So I am very curious - is that any issue you can solve or am I doing something wrong here?
Thank you in advance.

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 13 Mar 2019, 17:37
by Team@Mixvibes
Hello DJ Mate,

Sorry about this strange bug with the MC 6000.Also please register your license key/serial number for Cross (check out the grey header above this topic)

Unfortunately I do not have a MC 6000 here to test but most likely there is a slight bug with the MIDI mapping file for those controls. Let me know the exact version of Cross you have installed, since it might be a bug that was addressed in later versions (also registering will give you access to all Cross updates).

Regards,

Adam @Mixvibes

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 14 Mar 2019, 03:07
by DJ Mate
Hello, thank you for reminding me, I've registered software just now. Answering your question - I'm using Cross DJ 3.4.3 (64-bit) on Win 10. Best regards. Mateusz

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 25 Apr 2019, 01:35
by DJ Mate
Unfortunately, it looks like a problem I described above is more complicated. After recording a few mixes I've noticed that there are more issues with the knobs from the monitor and master sections. They do not work fully properly in their basic functions (sometimes it can also be seen on the computer screen, because they catch lags or do not react), and additionally each of them seems to affects the master / cue balance and the left / right balance in a strange way. Thank you in advance for any help, best regards.

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 25 Apr 2019, 09:25
by RoJeC
Really strange thing you describe.
You can try working with your mapping by creating and select a copy of the mapping file (x2 button for copy).

Change in L/R balance would be strange as Cross does not have this option.
Could you please tell which routing setting you use.
You can also try selecting the 14bit setting in Preferences >MIDI.

FigDJ might be able to provide more specific info. I just tried to mention some general options available.

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 25 Apr 2019, 12:45
by DJ Mate
I use split mono routing. It may just be my impression about l/r balance if there are cue/master issues which are giving same result. Anyway I eventually have figured out some settings that works for me and will move on but I think problem is still unsolved. Best regards and thank you for help!

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 25 Apr 2019, 13:29
by FigDJ
DJ Mate wrote:I use split mono routing. It may just be my impression about l/r balance if there are cue/master issues which are giving same result. Anyway I eventually have figured out some settings that works for me and will move on but I think problem is still unsolved. Best regards and thank you for help!


Post your current map so I can examine it and do some research on your problem. I have mapped the 4000 and 6000MK2 so there should be pretty similar.

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 25 Apr 2019, 15:46
by DJ Mate
DN-MC6000(Denon).mappings
denon mc6000 mappings
(185.02 KiB) Downloaded 64 times

Here is mapping but now I understand that if there is a problem then it's probably only with cue/master pan knob. When I use split mono option and I turn the pan from neutral to master, it seems to work ok, but from neutral to cue I get silence not the cued track. There are also some minor visual problems with knobs visually not responding or staying in old position. Rest of mentioned things is because of split mono option but I haven't recognized that earlier and just had to find right setup to hear what I want.

Re: Is there minor issue with Denon MC6000 Mk1 mapping?

PostPosted: 25 Apr 2019, 21:56
by RoJeC
Split mono indeed will cause differences in L/R as you split the cue to one and Main to the other side.
This however is independent of MIDI. Other than availabilty of commands that fit the routing.
Dual stereo is the common way to work. Or if you only have one stereo output you can use a DJ-splitter (not a common stereo splitter). However pretty likely your controller supports dual stereo.